読者です 読者をやめる 読者になる 読者になる

SparkでAPIサーバを起動しようとしたらエラー

  • この記事を参考にSparkを使ってGroovyでWebAPIサーバ書こうと思ってる。

qiita.com

sparkjava.com

エラー発生!

:compileGroovy FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileGroovy'.
> spark/Spark : Unsupported major.minor version 52.0

原因

  • Javaのバージョンが1.7だったかららしい。1.8にしたら直った。
    • もう1.7だめかなー。うーんどうしよう。。。

Sparkとってもシンプルで書きやすいし、いい感じなので使いたいなー。1.8と1.7混在でもいいかな・・・。